Support Portal Update

Incident
11 April 2025, 16:15 UTC

Support Portal Update

Status: closed
Start: 05 April 2025, 00:15 UTC
End: 11 April 2025, 16:15 UTC
Duration: 6 days 16 hours
Affected Components:
Fastly Customer Services Support Systems https://support.fastly.com Chatbot Feature New Support Case
Affected Groups:
All Public Users
Update

05 April 2025, 00:15 UTC

05 April 2025, 00:15 UTC

The Fastly Support Portal (https://support.fastly.com/s/) has been temporarily disabled due to elevated errors during web form submission.

During this time the Fastly Support Portal will remain unavailable and customers may experience errors when attempting to access the Fastly Support Portal.

Fastly is currently monitoring this event closely and we will re-enable access to the portal when the errors have been mitigated.

Support Chat and Support Email will remain available and are unaffected by this event. We do not anticipate any negative impact to our service level agreements (SLAs) related to support response times by our support engineers.

Customers can contact Support via email at support@fastly.com or visit our Community page (https://community.fastly.com/) for answers to common questions and the latest updates.

Update

07 April 2025, 14:37 UTC

07 April 2025, 14:37 UTC

Our engineers are continuing to investigate elevated errors to our Support Portal. 

All other contact channels to our Support team remain unaffected by this event.

Identified

07 April 2025, 14:44 UTC

07 April 2025, 14:44 UTC

Our engineers have identified the contributing factors that were leading to a poor customer experience with our webpage form and chatbot tooling. Our Support Portal web-page is accessible, however these chatbot and new ticket creation features within our web-page have been temporarily disabled.

Customers who wish to open new support cases with our Support team are asked to engage their designated account teams, email support@fastly.com or request assistance through their Support Chat (Slack-based) toolsets.

Our chatbot and support cases tooling through the access of our web-page (https://support.fastly.com) will remain deactivated until long-term solutions have been confirmed with our third-party vendor. We acknowledge the inconvenience of this issue and want our customers to know that we are investigating into various solutions as a high priority. 

This incident has no impact to our ability to deliver Network services or any other product/services.

Update

07 April 2025, 15:05 UTC

07 April 2025, 15:05 UTC

Note: We have added two new components, the Chatbot Feature and New Support Case, to our status page. These components will be located under our Support Portal webpage component at https://support.fastly.com. As a result of this update, we have made adjustments to the affected components listed in this status post.

Update

08 April 2025, 00:25 UTC

08 April 2025, 00:25 UTC

Engineering has confirmed the impact to our Chatbot tooling has been mitigated. 

Our Chatbot Feature has been fully restored and is available on our web-page (https://support.fastly.com). 

The Fastly New Support Case feature remains deactivated.

Resolved

11 April 2025, 16:15 UTC

11 April 2025, 16:15 UTC

We have posted the date and time that this maintenance will be performed, and as a result will close this status post and refer all interested subscribers to: https://www.fastlystatus.com/incident/377465 for more information. Thank you for your patience.