Retrospective: Impacted Performance in Fastly Application Audit Logs

Informational
31 March 2025, 16:00 UTC

Retrospective: Impacted Performance in Fastly Application Audit Logs

Status: closed
Date: 27 March 2025, 22:00 UTC
End: 31 March 2025, 16:00 UTC
Duration: 3 days 18 hours
Affected Components:
Fastly Fastly Application API & Configuration Management Notification Center API Services Configuration Management Services
Affected Groups:
All Public Users
Monitoring

27 March 2025, 22:00 UTC

27 March 2025, 22:00 UTC

Fastly Engineers detected an event affecting the Fastly Application Audit Logs.

All other data centers and services were unaffected. The issue has been resolved and we are monitoring performance closely.

Resolved

31 March 2025, 16:00 UTC

31 March 2025, 16:00 UTC

During this incident, customers may have experienced duplicated audit logs from the 27th of March 22:00 to the 31st of March 16:00 UTC.

This incident is resolved.

For more information about this retrospective status post, please reach out to Support through https://support.fastly.com.