(Informational Only) Account Management System Audit and Efficiency Procedure

Maintenance
03 April 2025, 00:00 UTC

(Informational Only) Account Management System Audit and Efficiency Procedure

Status: closed
Start: 02 April 2025, 16:00 UTC
End: 03 April 2025, 00:00 UTC
Duration: 8 hours
Affected Components:
Fastly Customer Services General Updates
Affected Groups:
All Public Users
Update

02 April 2025, 16:00 UTC

02 April 2025, 16:00 UTC

As part of an initiative to enhance operational efficiency across our platform, Fastly will conduct a systematic audit of the Account Management system. This audit will involve the removal of inactive Trial accounts and their associated data.

Current Trial accounts meeting the following criteria will be permanently deleted from our systems:

  • Trial Accounts exhibiting no login activity for a period of six months or greater.
  • Trial Accounts demonstrating no associated traffic for a consecutive period of six months or greater.

All other account types will not be affected by this procedure.

This procedure will not impede our ability to provide services to our customers.

Customers with inquiries or concerns are encouraged to contact our Support team via email at support@fastly.com or their designated account management personnel.

Resolved

03 April 2025, 00:00 UTC

03 April 2025, 00:00 UTC

To offer feedback on our status page, click "Give Feedback