Upcoming Maintenance to Enhance manage.fastly.com

Informational
19 March 2025, 17:40 UTC

Upcoming Maintenance to Enhance manage.fastly.com

Status: closed
Date: 19 March 2025, 17:00 UTC
End: 19 March 2025, 17:40 UTC
Duration: 40 minutes
Affected Components:
Fastly Fastly Application API & Configuration Management Configuration Management Services
Affected Groups:
All Public Users
Update

19 March 2025, 17:00 UTC

19 March 2025, 17:00 UTC

What's Changing?

We will be conducting planned maintenance on the Fastly Control Panel to modernize it for current web-standards and to embrace its own latest product-offerings.  Services that support the manage.fastly.com site will be modified to enable our Next-Gen WAF (NGWAF) and Managed Security Services (MSS) to result in a more secure web experience.

Our remaining maintenance activity will start on the 19th of March 2025 at 17:00 UTC and our estimated duration is [~40 minutes].

Customers may experience a temporary error, not expected to last the full duration of this maintenance, when attempting to log into manage.fastly.com.

This maintenance will have no impact on our ability to deliver Network or Security services to our customers. Additionally, no data will be lost and we do not anticipate any impact to API services.

When this maintenance is completed, access to the Fastly Control Panel will be stabilized, have better security features, and will be more performant.

What's next? What do I have to do?

Nothing. All actions taken during this planned maintenance belong to Fastly. 

Customers with any questions or concerns may engage with our Support team through https://support.fastly.com or by contacting your designated account management team members.

Resolved

19 March 2025, 17:40 UTC

19 March 2025, 17:40 UTC

The scheduled maintenance has been completed.

To offer feedback on our status page, click "Give Feedback