Data Center Capacity Expansion for Denver (DEN)

Maintenance
07 March 2025, 01:00 UTC

Data Center Capacity Expansion for Denver (DEN)

Status: closed
Start: 06 March 2025, 13:00 UTC
End: 07 March 2025, 01:00 UTC
Duration: 12 hours
Affected Components:
Platform North America Denver (DEN)
Affected Groups:
All Public Users
Update

06 March 2025, 13:00 UTC

06 March 2025, 13:00 UTC

Fastly will be adding capacity at our Denver (DEN) POP. End-users may observe connection resets as traffic is migrated onto new hardware starting on 06 March 2025 at 13:00 UTC.

Our estimated duration is 4h. 

When this change is applied, customers may observe additional origin traffic as new cache nodes retrieve content from origin. Please verify that your origin access lists allow the full range of Fastly IP addresses (https://docs.fastly.com/en/guides/accessing-fastlys-ip-ranges). Customers with any questions or concerns should contact Fastly’s Support team (support@fastly.com).

Update

06 March 2025, 17:50 UTC

06 March 2025, 17:50 UTC

Scheduled maintenance is currently in progress. We will provide updates as necessary.

Update

06 March 2025, 21:12 UTC

06 March 2025, 21:12 UTC

Fastly Engineering has extended the scheduled maintenance and is currently in progress. We will provide updates as necessary.

Resolved

07 March 2025, 01:00 UTC

07 March 2025, 01:00 UTC

The scheduled maintenance has been completed.

To offer feedback on our status page, click "Give Feedback