Retrospective: Impacted Availability in Fastly Application

Informational
21 February 2025, 19:20 UTC

Retrospective: Impacted Availability in Fastly Application

Status: closed
Date: 21 February 2025, 18:52 UTC
End: 21 February 2025, 19:20 UTC
Duration: 28 minutes
Affected Components:
Fastly Fastly Application API & Configuration Management Notification Center API Services Configuration Management Services
Affected Groups:
All Public Users
Monitoring

21 February 2025, 18:52 UTC

21 February 2025, 18:52 UTC

Fastly Engineers detected an availability impacting event affecting the Fastly Application service.

All other data centers and services were unaffected. The issue has been resolved and we are monitoring performance closely.

Resolved

21 February 2025, 19:20 UTC

21 February 2025, 19:20 UTC

Engineering has confirmed that Fastly Application service has been fully restored. Customers with a role lower than "billing" may have experienced elevated 403 errors from 18:52 to 19:20 UTC.

This incident is resolved.

To offer feedback on our status page, click "Give Feedback

Status Post, Created Date/Time: 0001-01-01 00:00:00 UTC 



Note: Our Customer Escalation Management team will update the start date and time of the initial "investigating" status post upon the resolution of this incident. This update is meant to provide our customers and their end users with a potential impact window. The date and time mentioned in the message above indicates when the status post was requested by our Acute Incident Response team.