Elevated Errors for General Updates, Notification Center

Informational
21 February 2025, 00:20 UTC

Elevated Errors for General Updates, Notification Center

Status: closed
Date: 20 February 2025, 02:38 UTC
End: 21 February 2025, 00:20 UTC
Duration: 21 hours 42 minutes
Affected Components:
Fastly Customer Services Fastly Application Notification Center General Updates
Affected Groups:
All Public Users
Investigating

20 February 2025, 02:38 UTC

20 February 2025, 02:38 UTC

We are currently investigating elevated errors in our Fastly Application related to the recently released General Updates, Notification Center feature.

Impacted customers would have received two notifications about a new version of Fastly CLI to support Rust v.1.84. Although the message mentions an attachment, customers may will not find a "download pdf" option upon logging in.

This incident does not affect our ability to provide Fastly services. Our customers should not be experiencing any performance issues as a result of this situation.

Identified

20 February 2025, 21:34 UTC

20 February 2025, 21:34 UTC

Our engineers have identified the contributing factor and are applying a fix to our General Updates, Notification Center service.

This incident does not affect our ability to provide Fastly services. Our customers should not be experiencing any performance issues as a result of this situation.

Monitoring

20 February 2025, 23:06 UTC

20 February 2025, 23:06 UTC

Engineering has confirmed the impact to General Updates, Notification Center service has been mitigated.

This incident does not affect our ability to provide Fastly services. Our customers should not be experiencing any performance issues as a result of this situation.

Resolved

21 February 2025, 00:20 UTC

21 February 2025, 00:20 UTC

Engineering has confirmed that the Notification Center within the Fastly Application has been fully restored.

Impacted customers will now have access to download the .pdf that was attached to the message distributed by our Escalation Management team, with the subject line:

  • Action Required (follow up) : New Version of Fastly CLI to Support Rust v1.84 (with attachment)


Customers would not have been able to download the shared message from the 20th of February at 02:38 UTC to the 21st of February at 00:20 UTC.