Seattle (BFI) Maintenance

Maintenance
23 January 2025, 13:00 UTC

Seattle (BFI) Maintenance

Status: closed
Start: 23 January 2025, 09:00 UTC
End: 23 January 2025, 13:00 UTC
Duration: 4 hours
Affected Components:
Platform North America Seattle (BFI)
Affected Groups:
All Public Users
Update

23 January 2025, 09:00 UTC

23 January 2025, 09:00 UTC

Fastly will be performing scheduled maintenance on our Seattle (BFI) data center from 23 January 2025, 09:00 UTC - 23 January 2025, 13:00 UTC.

During this time frame traffic in BFI will be operating with reduced capacity and some traffic will be redirected to neighboring POPs in the region.

Resolved

23 January 2025, 13:00 UTC

23 January 2025, 13:00 UTC

The scheduled maintenance has been completed.

To offer feedback on our status page, click "Give Feedback