Amsterdam (RTM) New Data Center

Maintenance
28 January 2025, 03:00 UTC

Amsterdam (RTM) New Data Center

Status: closed
Start: 27 January 2025, 22:00 UTC
End: 28 January 2025, 03:00 UTC
Duration: 5 hours
Affected Components:
Platform Europe Amsterdam (RTM)
Affected Groups:
All Public Users
Update

27 January 2025, 22:00 UTC

27 January 2025, 22:00 UTC

As part of Fastly’s global network expansion, we will be adding Amsterdam (RTM) data center to Fastly's Europe network. 

Traffic served by our Amsterdam (RTM) data center will be aggregated into our Europe region for billing and stats purposes.

We expect that some traffic currently served by our data centers in neighboring regions will shift to Amsterdam (RTM). As such, some customers may see a change in their bills.

Fastly’s standard billing rates are located at https:/www.fastly.com/pricing.

Resolved

28 January 2025, 03:00 UTC

28 January 2025, 03:00 UTC

The scheduled maintenance has been completed.

To offer feedback on our status page, click "Give Feedback