Retrospective: Impacted Performance in Seattle (BFI)

Informational
16 January 2025, 00:57 UTC

Retrospective: Impacted Performance in Seattle (BFI)

Status: closed
Date: 16 January 2025, 00:45 UTC
End: 16 January 2025, 00:57 UTC
Duration: 12 minutes
Affected Components:
Platform North America Seattle (BFI)
Affected Groups:
All Public Users
Monitoring

16 January 2025, 00:45 UTC

16 January 2025, 00:45 UTC

Fastly Engineers detected a performance impacting event affecting the Seattle (BFI) data center.

All other data centers and services were unaffected. The issue has been resolved and we are monitoring performance closely.

Resolved

16 January 2025, 00:57 UTC

16 January 2025, 00:57 UTC

During this incident, customers may have experienced network errors displayed as broken connections from 00:45 to 00:57 UTC.

This incident is resolved.

For more information about this retrospective status post, please reach out to Support through https://support.fastly.com.