Elevated Errors for our Europe and North America Regions

Incident
23 July 2024, 23:52 UTC

Elevated Errors for our Europe and North America Regions

Status: closed
Start: 23 July 2024, 12:48 UTC
End: 23 July 2024, 23:52 UTC
Duration: 11 hours 4 minutes
Affected Components:
Platform North America Europe Amsterdam (AMS) Brussels (BRU) Ashburn (IAD) Copenhagen (CPH) Dublin (DUB) Frankfurt (FRA) Frankfurt (HHN) Atlanta (PDK) Helsinki (HEL) Boston (BOS) London (LCY) Calgary (YYC) London (LON) Chicago (CHI) London (LHR) Lisbon (LIS) Madrid (MAD) Manchester (MAN) Marseille (MRS) Milan (LIN) Milan (MXP) Columbus (CMH) Oslo (OSL) Columbus (LCK) Munich (MUC) Palermo (PMO) Dallas (DFW) Denver (DEN) Paris (CDG) Detroit (DTW) Paris (PAR) Rome (FCO) Gainesville (GNV) Sofia (SOF) Honolulu (HNL) Stockholm (BMA) Houston (IAH) Vienna (VIE) Kansas City (MCI) Los Angeles (BUR) Los Angeles (LAX) Miami (MIA) Minneapolis (MSP) Minneapolis (STP) Montreal (YUL) Newark (EWR) New York (LGA) New York (NYC) Palo Alto (PAO) Phoenix (PHX) Portland (PDX) San Jose (SJC) Seattle (BFI) St. Louis (STL) Toronto (YYZ) Vancouver (YVR)
Affected Groups:
All Public Users
Identified

23 July 2024, 12:48 UTC

23 July 2024, 12:48 UTC

At approximately 08:00 UTC our engineers began to investigate a large traffic event impacting performance within our Europe and North America regions. 

Standard traffic engineering practices have been deployed in response to this event, in an effort to reduce the potential impact to our customers within the regions. Customer may continue to see elevated errors and latency as mitigation efforts continue to be deployed.

All other products and services are unaffected by this incident.

Update

23 July 2024, 14:29 UTC

23 July 2024, 14:29 UTC

Our engineers are implementing adjusted mitigation strategies in our North America and Europe regions to continue to balance traffic and manage performance.

Error rates and latency have improved, although customers may still experience intermittent periods of performance impact as traffic engineering continues to be deployed.

Monitoring

23 July 2024, 16:37 UTC

23 July 2024, 16:37 UTC

Engineering has implemented mitigation strategies and has confirmed a gradual recovery in our North America and Europe regions. 

We are closely monitoring performance in these regions as a top priority as this event continues and will provide a final update once customer and end user experience has been fully restored.

Resolved

23 July 2024, 23:52 UTC

23 July 2024, 23:52 UTC

Engineering has confirmed that Europe and North America regions have been fully restored. Customers may have experienced elevated errors and latency from 08:00 to 16:37 UTC.

This incident is resolved.

Affected customers would have experienced impact to varying degrees and to a shorter duration than as set forth above.

To offer feedback on our status page, click "Give Feedback