Elevated Errors for API Services

Incident
22 July 2024, 23:12 UTC

Elevated Errors for API Services

Status: closed
Start: 22 July 2024, 21:13 UTC
End: 22 July 2024, 23:12 UTC
Duration: 1 hour 59 minutes
Affected Components:
Fastly Fastly Application API & Configuration Management API Services
Affected Groups:
All Public Users
Investigating

22 July 2024, 21:13 UTC

22 July 2024, 21:13 UTC

We are investigating elevated errors to our API Services.

Identified

22 July 2024, 22:08 UTC

22 July 2024, 22:08 UTC

Our engineers have identified the contributing factor and are applying a fix to our API Services.

Monitoring

22 July 2024, 22:59 UTC

22 July 2024, 22:59 UTC

Engineering has deployed a fix and have confirmed a gradual recovery to our API Services. We will continue to monitor until we’ve confirmed that customer experience has been fully restored.

Resolved

22 July 2024, 23:12 UTC

22 July 2024, 23:12 UTC

Engineering has confirmed that our API Services have been fully restored. Customers may have experienced both the UI and API endpoint failures from 21:13 to 23:30 UTC.

This incident is resolved.

Affected customers may have experienced impact to varying degrees and to a shorter or longer duration than as set forth above.

To offer feedback on our status page, click "Give Feedback