Elevated Errors for KV Store

Incident
14 June 2024, 16:30 UTC

Elevated Errors for KV Store

Status: closed
Start: 13 June 2024, 11:17 UTC
End: 14 June 2024, 16:30 UTC
Duration: 1 day 5 hours 13 minutes
Affected Components:
Compute Fastly Compute KV Store
Affected Groups:
All Public Users
Investigating

13 June 2024, 11:17 UTC

13 June 2024, 11:17 UTC

We are investigating elevated errors to our KV Store service.

Identified

13 June 2024, 11:38 UTC

13 June 2024, 11:38 UTC

Our engineers have identified the contributing factor and are applying a fix to our KV Store service.

Monitoring

13 June 2024, 12:13 UTC

13 June 2024, 12:13 UTC

Engineering has deployed a fix and have confirmed a gradual recovery to our KV Store service. We will continue to monitor until we’ve confirmed that customer experience has been fully restored.

Resolved

14 June 2024, 16:30 UTC

14 June 2024, 16:30 UTC

Engineering has confirmed that KV Store service has been fully restored. Customers may have observed KVStoreNotFound errors in a portion of their call to some functions if the key is not found from 11:17 on the 13th of June 2024 to 16:30 on the 14th of June 2024 UTC.

This incident is resolved.

To offer feedback on our status page, click "Give Feedback