Rust SDK 0.10.0. Possible Impact for Response::with_header() Users

Informational
07 June 2024, 00:03 UTC

Rust SDK 0.10.0. Possible Impact for Response::with_header() Users

Status: closed
Date: 06 June 2024, 20:00 UTC
End: 07 June 2024, 00:03 UTC
Duration: 4 hours 3 minutes
Affected Components:
Compute Fastly Compute Config Store KV Store Secret Store
Affected Groups:
All Public Users
Update

06 June 2024, 20:00 UTC

06 June 2024, 20:00 UTC

On the 22nd of April 2024, Fastly released an update to our SDK Changelog - Rust SDK 0.10.0. - in order to better align the behavior experienced when working with the request and response objects in Rust.

This Rust SDK is not backwards-compatible with prior versions of SDK.

A recent customer report has led our engineers to discover that customers who have used the Response::with_header() function in Rust will encounter unexpected behavior until the changes documented within our Changelog have been applied.

We have checked our open support cases and confirmed there are no active reports of impact by our customers. Fastly Compute customers working with the Response::with_header() function in the Rust SDK will need to apply the changes shared in our SDK Changelog to their application code.

Please engage with our Support team through https://support.fastly.com if you have questions and/or concerns.

Resolved

07 June 2024, 00:03 UTC

07 June 2024, 00:03 UTC

To offer feedback on our status page, click "Give Feedback