Impact to release of NGWAF Core NGINX Native On Premise Module

Incident
31 May 2024, 22:59 UTC

Impact to release of NGWAF Core NGINX Native On Premise Module

Status: closed
Start: 31 May 2024, 17:55 UTC
End: 31 May 2024, 22:59 UTC
Duration: 5 hours 4 minutes
Affected Components:
Security Next-Gen WAF (NGWAF)
Affected Groups:
All Public Users
Identified

31 May 2024, 17:55 UTC

31 May 2024, 17:55 UTC

Fastly has identified problems with the latest release of the NGINX native module on CentOS/RHEL systems. Customers who upgrade to the latest package may have install errors related to gpg signing.

Identified

31 May 2024, 22:08 UTC

31 May 2024, 22:08 UTC

Our engineers are continuing to apply the identified fix to our Next-Gen WAF (NGWAF) service.

All other locations and services are unaffected.

Monitoring

31 May 2024, 22:39 UTC

31 May 2024, 22:39 UTC

Engineering has confirmed the impact to Next-Gen WAF (NGWAF) service has been mitigated.

Resolved

31 May 2024, 22:59 UTC

31 May 2024, 22:59 UTC

Engineering has confirmed that Next-Gen WAF (NGWAF) service has been fully restored. Customers who attempted to install the latest released version of the NGWAF NGINX Native module on CentOS, RHEL, or Amazon Linux systems would have experienced an install error from the package manager due to gpg signing problems from17:55 to 22:32 UTC.

This incident is resolved.

Customers who did not attempt to upgrade their NGINX Native module during the period of impact were not impacted.

Only operating systems that use the yum package manager (such as CentOS, RHEL, or Amazon Linux) were impacted.

To offer feedback on our status page, click "Give Feedback