Docs Performance Issues

Incident
27 May 2024, 07:00 UTC

Docs Performance Issues

Status: closed
Start: 23 May 2024, 10:04 UTC
End: 27 May 2024, 07:00 UTC
Duration: 3 days 20 hours 56 minutes
Affected Components:
Fastly Customer Services Fastly Web Pages https://docs.fastly.com/
Affected Groups:
All Public Users
Investigating

23 May 2024, 10:04 UTC

23 May 2024, 10:04 UTC

We're currently investigating performance issues with the search functions on our docs.fastly.com webpage.

All other Fastly products and services are unaffected.

Investigating

27 May 2024, 06:03 UTC

27 May 2024, 06:03 UTC

Our engineers are continuing to investigate performance issues with the search functions on our https://docs.fastly.com/ webpage.

All other Fastly products and services are unaffected.

Identified

27 May 2024, 06:10 UTC

27 May 2024, 06:10 UTC

Our engineers have identified the contributing factor and are applying a fix to the search functions on our https://docs.fastly.com/ webpage.

All other Fastly products and services are unaffected.

Monitoring

27 May 2024, 06:49 UTC

27 May 2024, 06:49 UTC

Engineering has confirmed the impact to the search functions on our https://docs.fastly.com/ webpage has been mitigated.

Resolved

27 May 2024, 07:00 UTC

27 May 2024, 07:00 UTC

Engineering has confirmed that the search functions on our https://docs.fastly.com/ has been fully restored. Customers may have experienced the inability to perform a search on our documentation webpage from the 23rd of May 2024 at 10:04 to the 27th of May 2024 at 06:48 UTC.

All other Fastly products and services were unaffected.

This incident is resolved.