Retrospective: Impacted Performance in Houston (IAH)

Informational
25 May 2024, 23:03 UTC

Retrospective: Impacted Performance in Houston (IAH)

Status: closed
Date: 25 May 2024, 22:54 UTC
End: 25 May 2024, 23:03 UTC
Duration: 9 minutes
Affected Components:
Platform North America Houston (IAH)
Affected Groups:
All Public Users
Update

25 May 2024, 22:54 UTC

25 May 2024, 22:54 UTC

Fastly Engineers detected a performance impacting event affecting the Houston (IAH) data center.

All other data centers and services were unaffected. The issue has been resolved and we are monitoring performance closely.

Resolved

25 May 2024, 23:03 UTC

25 May 2024, 23:03 UTC

For more information about this retrospective status post, please reach out to Support through https://support.fastly.com.

This event has been resolved.