Origin Inspector Performance Issues

Incident
24 May 2024, 23:15 UTC

Origin Inspector Performance Issues

Status: closed
Start: 24 May 2024, 21:50 UTC
End: 24 May 2024, 23:15 UTC
Duration: 1 hour 25 minutes
Affected Components:
Observability Origin Inspector
Affected Groups:
All Public Users
Investigating

24 May 2024, 21:50 UTC

24 May 2024, 21:50 UTC

We're currently investigating performance issues with our Origin Inspector service.

All other services are unaffected.

Identified

24 May 2024, 22:36 UTC

24 May 2024, 22:36 UTC

Our engineers have identified the contributing factor and are applying a fix to our Origin Inspector service.

Monitoring

24 May 2024, 22:39 UTC

24 May 2024, 22:39 UTC

Engineering has deployed a fix and have confirmed a gradual recovery to our Origin Inspector service. We will continue to monitor until we’ve confirmed that customer experience has been fully restored.



Resolved

24 May 2024, 23:15 UTC

24 May 2024, 23:15 UTC

Engineering has confirmed that our Origin Inspector service has been fully restored. Customers may have experienced increased latency of Origin Inspector data being visible in the Historical Stats API from 21:50 to 23:15 UTC.

This incident is resolved.

Affected customers may have experienced impact to varying degrees and to a shorter duration than as set forth above.