Retrospective: Impacted Performance in Chicago (CHI)

Informational
22 May 2024, 12:00 UTC

Retrospective: Impacted Performance in Chicago (CHI)

Status: closed
Date: 22 May 2024, 11:32 UTC
End: 22 May 2024, 12:00 UTC
Duration: 28 minutes
Affected Components:
Platform North America Chicago (CHI)
Affected Groups:
All Public Users
Update

22 May 2024, 11:32 UTC

22 May 2024, 11:32 UTC

Fastly Engineers detected a performance impacting event affecting the Chicago (CHI) data center. Customers may have experienced elevated errors and latency.

All other data centers and services were unaffected. The issue has been resolved and we are monitoring performance closely.

Resolved

22 May 2024, 12:00 UTC

22 May 2024, 12:00 UTC

This event has been resolved.

Update 5/22 (13:20 UTC)

Following our retrospective of this incident, our Customer Escalations team updated our status post start time to reflect the earliest alert received by Fastly Engineers - start time has been confirmed as 11:32 UTC on the 22nd of May 2024.