General Update: Upcoming Changes to Let’s Encrypt’s Chain of Trust

Informational
18 April 2024, 14:49 UTC

General Update: Upcoming Changes to Let’s Encrypt’s Chain of Trust

Status: closed
Date: 18 April 2024, 13:49 UTC
End: 18 April 2024, 14:49 UTC
Duration: 1 hour
Affected Components:
General Updates
Affected Groups:
All Public Users
Update

18 April 2024, 13:49 UTC

18 April 2024, 13:49 UTC

A significant update from Let’s Encrypt, one of our integrated Certification Authorities (CA), may affect how customers access your website. On June 6th, 2024, Let’s Encrypt end-users on very old devices or software may receive insecure warnings or be blocked from accessing your applications. 


To protect your customer experience, we encourage you to confirm which CA you’re using. If it’s Lets Encrypt and serving this type of traffic is a hard requirement, consider changing your TLS subscription to Certainly.


Learn more about the change and how to confirm your CA here. Our customer support team is here to help if you have any additional questions. You can reach us at https://support.fastly.com


We are dedicated to providing all our customers a secure and reliable online experience. We appreciate your attention to this matter and your continued trust in us. Thank you for your understanding and cooperation.


Resolved

18 April 2024, 14:49 UTC

18 April 2024, 14:49 UTC

For more information please contact our Support team at https://support.fastly.com