Elevated Errors for Fastly Application

Incident
09 April 2024, 16:05 UTC

Elevated Errors for Fastly Application

Status: closed
Start: 09 April 2024, 15:40 UTC
End: 09 April 2024, 16:05 UTC
Duration: 25 minutes
Affected Components:
Compute Fastly Application API & Configuration Management API Services
Affected Groups:
All Public Users
Investigating

09 April 2024, 15:40 UTC

09 April 2024, 15:40 UTC

We are investigating elevated errors to our Fastly Application and the Fastly API.

Update: Our retrospective investigation has identified the initial onset of errors to have started at approximately 15:40 UTC.

Identified

09 April 2024, 15:58 UTC

09 April 2024, 15:58 UTC

Our engineers have identified the contributing factor and are applying a fix to Fastly API, Fastly Application.


Monitoring

09 April 2024, 16:01 UTC

09 April 2024, 16:01 UTC

Engineering has confirmed the impact to Fastly API, Fastly Application has been mitigated.

Resolved

09 April 2024, 16:05 UTC

09 April 2024, 16:05 UTC

Engineering has confirmed that Fastly API, Fastly Application has been fully restored. Customers may have experienced elevated errors when attempting to access manage.fastly.com and failed API services during this incident from 15:40 to 16:01 UTC. 

Our network availability and all other services were unaffected by this incident.

This incident is resolved.