Elevated Errors for our KV Store within our Compute Services

Incident
02 April 2024, 21:13 UTC

Elevated Errors for our KV Store within our Compute Services

Status: closed
Start: 02 April 2024, 20:28 UTC
End: 02 April 2024, 21:13 UTC
Duration: 45 minutes
Affected Components:
Compute Fastly Compute
Affected Groups:
All Public Users
Investigating

02 April 2024, 20:28 UTC

02 April 2024, 20:28 UTC

We are investigating elevated errors to our KV Store within our Compute Services.

Identified

02 April 2024, 20:39 UTC

02 April 2024, 20:39 UTC

Our engineers have identified the contributing factor and are applying a fix to Compute Services.


Monitoring

02 April 2024, 20:46 UTC

02 April 2024, 20:46 UTC

Engineering has confirmed the impact to Compute Services has been mitigated.

Resolved

02 April 2024, 21:13 UTC

02 April 2024, 21:13 UTC

Engineering has confirmed that the KV Store within our Compute Services has been fully restored. Customers may have experienced 5xx errors accessing the KV Store from 20:05 to 20:33 UTC.

This incident is resolved.