Fastly Application Performance Issues

Incident
25 March 2024, 21:27 UTC

Fastly Application Performance Issues

Status: closed
Start: 25 March 2024, 20:28 UTC
End: 25 March 2024, 21:27 UTC
Duration: 59 minutes
Affected Components:
Compute Fastly Application API & Configuration Management
Affected Groups:
All Public Users
Investigating

25 March 2024, 20:28 UTC

25 March 2024, 20:28 UTC

We are currently investigating performance issues affecting the availability of manage.fastly.com. CDN delivery, stats aggregation, and all other data plane services are unaffected.

Identified

25 March 2024, 20:45 UTC

25 March 2024, 20:45 UTC

Our engineers have identified the contributing factor and are applying a fix to Fastly Application.

Monitoring

25 March 2024, 21:05 UTC

25 March 2024, 21:05 UTC

Engineering has confirmed the impact to Fastly Application has been mitigated.

Resolved

25 March 2024, 21:27 UTC

25 March 2024, 21:27 UTC

Engineering has confirmed that Fastly Application has been fully restored. Customers may have experienced issues with login to the Fastly App from 20:14 to 20:36 UTC.

This incident is resolved.