Elevated Errors for Geolocation Data

Incident
05 March 2024, 21:52 UTC

Elevated Errors for Geolocation Data

Status: closed
Start: 04 March 2024, 22:48 UTC
End: 05 March 2024, 21:52 UTC
Duration: 23 hours 4 minutes
Affected Components:
Compute Geolocation Data
Affected Groups:
All Public Users
Investigating

04 March 2024, 22:48 UTC

04 March 2024, 22:48 UTC

We are investigating elevated errors to our Geolocation Data.

Monitoring

04 March 2024, 23:57 UTC

04 March 2024, 23:57 UTC

Engineering has confirmed the impact to Geolocation Data has been mitigated.

Monitoring

05 March 2024, 00:44 UTC

05 March 2024, 00:44 UTC

Our engineers have confirmed that the impact to our Geolocation services has been restored to pre-incident levels. There will be a scheduled deployment to further reduce the risk of future impact, and we will continue to monitor the service with a high priority until this updated configuration has been deployed.

Once our deployment has been confirmed, we will resolve this status post.

Resolved

05 March 2024, 21:52 UTC

05 March 2024, 21:52 UTC

Engineering has confirmed that Geolocation Data has been fully restored. Customers may have experienced failing Geolocation lookups in Compute from 11:00 to 20:00 UTC.

This incident is resolved.