Purging (URL/Key) System Performance Issues

Incident
29 February 2024, 14:04 UTC

Purging (URL/Key) System Performance Issues

Status: closed
Start: 27 February 2024, 19:50 UTC
End: 29 February 2024, 14:04 UTC
Duration: 1 day 18 hours 14 minutes
Affected Components:
Compute Purging
Affected Groups:
All Public Users
Investigating

27 February 2024, 19:50 UTC

27 February 2024, 19:50 UTC

Our engineers are currently investigating a bug affecting a subset of Purge services through our API. The bug is encountered when Purge services are requested using a batch method, when using JSON bodies or surrogate key vectors via Surrogate-Key.

Hash purges and simple surrogate key purges (using Fastly-Surrogate-Key header) are unaffected by this issue.

Our network availability and all other services are unaffected by this incident.

Status Post Update (Mar-8th):

We have retrospectively updated the start date and time to reflect the earliest onset of possible errors - as determined by our post-incident investigations. Customers may have experienced impact to varying degrees and to a shorter duration outline within this status post. 

Identified

28 February 2024, 23:40 UTC

28 February 2024, 23:40 UTC

Our engineers have confirmed the contributing factor for the bug, and are applying a fix for Purging services.


Monitoring

29 February 2024, 00:55 UTC

29 February 2024, 00:55 UTC

Engineering has deployed a bug fix for our Purging services. Our deployment will be deployed gradually across the fleet, and we will continue to monitor until we’ve confirmed that customer experience has been fully restored.

We do not anticipate any impact to our network availability or other services as a result of this deployment.



Resolved

29 February 2024, 14:04 UTC

29 February 2024, 14:04 UTC

Engineering has confirmed that Purging  has been fully restored. Customers may have experienced issues when Purge services are requested using a batch method, when using JSON bodies or surrogate key vectors via Surrogate-Key from the 27th of February 2024 19:50 UTC to the 29th of February 12:55 UTC.

This incident is resolved.

Affected customers may have experienced impact to varying degrees and to a shorter duration than as set forth above.

Status Post Updated: 02/29/2024 at 02:39 UTC

Engineers confirmed in retrospective investigations, that the earliest possible onset for this bug was at 19:50 UTC on the 27th of February 2024.