New Feature Launch: Unified Fastly and Signal Sciences Login Experience

Maintenance
22 March 2024, 15:34 UTC

New Feature Launch: Unified Fastly and Signal Sciences Login Experience

Status: closed
Start: 20 February 2024, 17:41 UTC
End: 22 March 2024, 15:34 UTC
Duration: 30 days 21 hours 53 minutes
Affected Components:
Compute Security Fastly Application Security Console & API API & Configuration Management Data Services Dashboard Data Rate Limiting and Alerts Requests Signals Dashboard
Affected Groups:
All Public Users
Update

20 February 2024, 17:41 UTC

20 February 2024, 17:41 UTC

Fastly is excited to announce the launch of a unified login experience across Fastly and Signal Sciences consoles to make it simpler and easier for you to access Fastly products and services using a single set of login credentials. Starting today, the 20th of February 2024, we'll be doing a gradual rollout of a new web interface as part of the upgraded login experience. A summary of the main changes appears below.

What's changing? 

Single set of credentials to login to Fastly and Signal Sciences console. Simplified login will allow you to use a single set of login credentials to access all products and features across Fastly's suite of offerings. If you have both Fastly and Signal Sciences accounts that use the same email address and use password and 2FA for authentication, you can use Fastly credentials to log in to both Fastly and Signal Science console.

Log in once and access both accounts. You have to sign-in only once and can switch between Fastly or Signal Sciences console seamlessly without having to log in again if you use the same email address.

Password and 2FA management in one place. You'll be able to change passwords and set up two-factor authentication directly in the Fastly console for both Fastly and Signal Sciences accounts.

Service Provider initiated SSO is now supported. You can log in directly at either Fastly or Signal Sciences console login page using SSO without going to your IdP page.

Password reset got simpler. You can reset your passwords without having to create a temporary password.

Account linking will no longer be required. Customers with both Fastly and Signal Sciences accounts will no longer need to manually link those accounts. Already have linked accounts? You won't need to do anything and can start using your Fastly credentials immediately.

New passwords will be required to conform to NIST guidelines. The complexity for new and changed passwords will be required to conform to digital identity guidelines from the National Institute of Standards and Technology (specifically, the NIST800-63B guidelines). Existing passwords won't be affected until you choose to update them.

Session timeouts will be standardized and more secure. We added additional measures to increase your security posture on the Fastly platform. You will be logged out after 30 minutes of inactivity. Session timeouts will also have a default maximum of 12 hours for any organization that hasn't set up single sign-on.

What's next? What do I have to do?

That's it!. The transition will be seamless and you are not required to take additional steps. You will see a new login experience when we enable this feature for you.

Please refer to documentation for additional information.

Still have questions? Feel free to contact your account manager or customer support for additional details.


Resolved

22 March 2024, 15:34 UTC

22 March 2024, 15:34 UTC

This maintenance has been extended and further updates will be shared on Continued Feature Launch: Unified Fastly and Signal Sciences Login Experience