Origin Inspector Performance Issues

Incident
20 December 2023, 03:50 UTC

Origin Inspector Performance Issues

Status: closed
Start: 19 December 2023, 18:51 UTC
End: 20 December 2023, 03:50 UTC
Duration: 8 hours 59 minutes
Affected Components:
Observability Origin Inspector
Affected Groups:
All Public Users
Investigating

19 December 2023, 18:51 UTC

19 December 2023, 18:51 UTC

We're currently investigating performance issues with our Origin Inspector service.

All other services are unaffected.

Identified

19 December 2023, 20:47 UTC

19 December 2023, 20:47 UTC

Our engineers have identified the contributing factor and are applying a fix to Origin Inspector

Monitoring

19 December 2023, 23:11 UTC

19 December 2023, 23:11 UTC

Engineering has deployed a fix and have confirmed a gradual recovery to Origin Inspector. We will continue to monitor until we’ve confirmed that customer experience has been fully restored.

Resolved

20 December 2023, 03:50 UTC

20 December 2023, 03:50 UTC

Engineering has confirmed that our Origin Inspector service has been fully restored. Customers may have experienced missing historical Origin Inspector metrics in both the APIs and web interface from the 14th December 2023 at 00:00 to the 20th of December 2023 at 03:18 UTC.

This incident is resolved.