Elevated Errors for Compute Services

Incident
06 December 2023, 05:24 UTC

Elevated Errors for Compute Services

Status: closed
Start: 06 December 2023, 04:31 UTC
End: 06 December 2023, 05:24 UTC
Duration: 53 minutes
Affected Components:
Compute Fastly Compute
Affected Groups:
All Public Users
Investigating

06 December 2023, 04:31 UTC

06 December 2023, 04:31 UTC

We are investigating elevated errors to our Compute Services. During this time, customers may experience elevated 5xx errors for Compute requests on affected nodes.

Identified

06 December 2023, 04:42 UTC

06 December 2023, 04:42 UTC

Our engineers have identified the contributing factor and are applying a fix to Compute Services.

All other locations and services are unaffected.

Monitoring

06 December 2023, 04:56 UTC

06 December 2023, 04:56 UTC

Engineering has deployed a fix and are monitoring the results. 

Resolved

06 December 2023, 05:24 UTC

06 December 2023, 05:24 UTC

Our engineers have confirmed that Compute services have been fully restored.

Customers in our Mumbai (BOM) Point of Presence (POP) may have seen intermittent 5xx errors for Compute services from 02:40 to 03:53 UTC, while customers in our Hong Kong (HKG) POP may have observed similar errors from 03:30 to 04:06 UTC.

All other locations and services were unaffected.