Elevated Errors Observed on our Fastly App and API Services

Incident
31 October 2023, 18:25 UTC

Elevated Errors Observed on our Fastly App and API Services

Status: closed
Start: 31 October 2023, 17:34 UTC
End: 31 October 2023, 18:25 UTC
Duration: 51 minutes
Affected Components:
Compute Fastly Application API & Configuration Management API Services Configuration Management Services
Affected Groups:
All Public Users
Investigating

31 October 2023, 17:34 UTC

31 October 2023, 17:34 UTC

We are currently investigating intermittent latency when attempting to access our Fastly App at manage.fastly.com and elevated errors observed for api.faslty.com services. 

Identified

31 October 2023, 17:56 UTC

31 October 2023, 17:56 UTC

This issue has been identified and a fix is being implemented. 

Monitoring

31 October 2023, 18:00 UTC

31 October 2023, 18:00 UTC

Earlier latency and elevated errors reported have subsided, a fix is being implemented and we are monitoring the results.

Resolved

31 October 2023, 18:25 UTC

31 October 2023, 18:25 UTC

Fastly App and API services have full recovered, our last recorded error was at ~17:30 UTC and we have not observed a recurrence.

This incident is resolved.