Image Optimizer Performance Issues

Incident
25 October 2023, 18:34 UTC

Image Optimizer Performance Issues

Status: closed
Start: 25 October 2023, 16:55 UTC
End: 25 October 2023, 18:34 UTC
Duration: 1 hour 39 minutes
Affected Components:
Compute Image Optimization
Affected Groups:
All Public Users
Investigating

25 October 2023, 16:55 UTC

25 October 2023, 16:55 UTC

We're currently investigating performance issues with our Image Optimization service.

All other services are unaffected.

Monitoring

25 October 2023, 18:10 UTC

25 October 2023, 18:10 UTC

A fix has been implemented and we are monitoring the results.

Resolved

25 October 2023, 18:34 UTC

25 October 2023, 18:34 UTC

This incident has been resolved.

----------------------

Update added on 27th OCT 2023

On Wednesday, the 25th of October 2023, Fastly received customer reports of elevated 5xx errors for Image Optimization services from 13:00 to 17:39 UTC. 

Our network availability, point of presence locations and all other services were unaffected by this incident.

Affected customers may have experienced impact to varying degrees and to a shorter duration than as set forth above.