Errors Switching Accounts within Our Fastly Control Plane

Incident
18 October 2023, 21:28 UTC

Errors Switching Accounts within Our Fastly Control Plane

Status: closed
Start: 18 October 2023, 17:03 UTC
End: 18 October 2023, 21:28 UTC
Duration: 4 hours 25 minutes
Affected Components:
Compute Fastly Application API & Configuration Management API Services Configuration Management Services
Affected Groups:
All Public Users
Identified

18 October 2023, 17:03 UTC

18 October 2023, 17:03 UTC

Our engineers have identified an error within our Control Plane for customers with multiple accounts. Customers attempting to switch accounts within the user interface may encounter an error preventing them from accessing their other accounts. 

Our network availability, scheduled API services, and all other locations and services are unaffected by this incident.

The cause of the issue has been identified and a fix is being implemented.

Monitoring

18 October 2023, 20:47 UTC

18 October 2023, 20:47 UTC

Our engineers have deployed a fix to restore our Control Plane functionality. We have confirmed a gradual recovery for impacted services and will continue to monitor until all customers have been fully restored.

Our network availability, api services and all other Point of Presence locations are unaffected by this incident.

Resolved

18 October 2023, 21:28 UTC

18 October 2023, 21:28 UTC

This incident has been resolved.