VCL Websocket Performance Issues

Incident
15 September 2023, 18:27 UTC

VCL Websocket Performance Issues

Status: closed
Start: 08 September 2023, 23:45 UTC
End: 15 September 2023, 18:27 UTC
Duration: 6 days 18 hours 42 minutes
Affected Components:
Compute Edge Cloud Services
Affected Groups:
All Public Users
Investigating

08 September 2023, 23:45 UTC

08 September 2023, 23:45 UTC

We’re currently investigating performance issues with our VCL websockets.

All other services are unaffected.

Monitoring

09 September 2023, 00:03 UTC

09 September 2023, 00:03 UTC

A fix has been implemented and we are monitoring the results.

Resolved

15 September 2023, 18:27 UTC

15 September 2023, 18:27 UTC

This incident has been resolved.

On the 8th of September 2023, Fastly Support and dedicated Technical Account teams received reports of intermittent WebSocket error messages from a subset of Fastly customers. Fastly Engineering identified one of our recent configuration deployments had resulted in the customer experience reported. To limit the impact we immediately identified a workaround, and distributed the instructions to all of our impacted customers.

As of the 15th September 2023 a corrected configuration has been effectively deployed throughout our infrastructure.

Those customers previously impacted by this incident, will be provided with a Fastly Service Advisory (FSA) outlining the details of this incident and the corrective measures that we have taken.

All other customer services and Point of Presence (POP) locations were unaffected by this incident.