Historical Stats Performance Issues

Incident
11 August 2023, 16:10 UTC

Historical Stats Performance Issues

Status: closed
Start: 11 August 2023, 11:57 UTC
End: 11 August 2023, 16:10 UTC
Duration: 4 hours 13 minutes
Affected Components:
Compute Observability Fastly Application Historical Stats API & Configuration Management
Affected Groups:
All Public Users
Investigating

11 August 2023, 11:57 UTC

11 August 2023, 11:57 UTC

We're currently investigating performance issues with our Historical Stats service.

All other services are unaffected.

Identified

11 August 2023, 12:19 UTC

11 August 2023, 12:19 UTC

This issue has been identified and a fix is being implemented. 

Identified

11 August 2023, 14:24 UTC

11 August 2023, 14:24 UTC

Fastly Engineering is applying additional mitigation strategies to fix our historical stats API. Customers may continue to experience 5xx errors in their Historical Stats API as we deploy these measures.

Investigating

11 August 2023, 15:38 UTC

11 August 2023, 15:38 UTC

Upon further investigation, Fastly Engineering has also identified impact with our Fastly Application that may be affecting customers.  

Customers may experience degraded service with the Historical Stats API and Fastly Application when attempting to collect data.

Identified

11 August 2023, 15:50 UTC

11 August 2023, 15:50 UTC

This issue has been identified and a fix is being implemented. 

Monitoring

11 August 2023, 15:55 UTC

11 August 2023, 15:55 UTC

A fix has been implemented and we are monitoring the results.

Resolved

11 August 2023, 16:10 UTC

11 August 2023, 16:10 UTC

This incident has been resolved.