Fastly WAF Performance Issues

Incident
16 June 2023, 17:22 UTC

Fastly WAF Performance Issues

Status: closed
Start: 16 June 2023, 16:32 UTC
End: 16 June 2023, 17:22 UTC
Duration: 50 minutes
Affected Components:
Security Agents and Module Rule and IP List updates
Affected Groups:
All Public Users
Identified

16 June 2023, 16:32 UTC

16 June 2023, 16:32 UTC

Fastly Engineering observed the NGWAF decisioning engine not checking new requests against customer rules. New IP flags are also delayed during this time.

All other services are unaffected.

Monitoring

16 June 2023, 17:11 UTC

16 June 2023, 17:11 UTC

A fix has been implemented and we are monitoring the results.

Resolved

16 June 2023, 17:22 UTC

16 June 2023, 17:22 UTC

This incident has been resolved.