Retrospective: Fastly WAF Performance Issues

Informational
15 June 2023, 20:20 UTC

Retrospective: Fastly WAF Performance Issues

Status: closed
Date: 15 June 2023, 19:48 UTC
End: 15 June 2023, 20:20 UTC
Duration: 32 minutes
Affected Components:
Security Agents and Module Rule and IP List updates
Affected Groups:
All Public Users
Update

15 June 2023, 19:48 UTC

15 June 2023, 19:48 UTC

From 15 June 2023, 19:48 UTC to 15 June 2023, 20:20  UTC Fastly Engineering observed the NGWAF decisioning engine not check new requests against customer rules. New IP flags were also delayed during this time. All other services during this time were unaffected.

Resolved

15 June 2023, 20:20 UTC

15 June 2023, 20:20 UTC

This incident has been resolved.