Billing System Issues

Incident
03 May 2023, 16:06 UTC

Billing System Issues

Status: closed
Start: 01 May 2023, 19:08 UTC
End: 03 May 2023, 16:06 UTC
Duration: 1 day 20 hours 57 minutes
Affected Components:
General Updates
Affected Groups:
All Public Users
Investigating

01 May 2023, 19:08 UTC

01 May 2023, 19:08 UTC

Fastly is currently investigating an issue with the billing system, including the billing portions of the Fastly configuration application and API.

Edge delivery, stats aggregation, and all other services are unaffected.

Identified

02 May 2023, 17:39 UTC

02 May 2023, 17:39 UTC

This issue has been identified and a fix is being implemented. 

Monitoring

02 May 2023, 21:25 UTC

02 May 2023, 21:25 UTC

A fix has been implemented and we are monitoring the results.

Resolved

03 May 2023, 16:06 UTC

03 May 2023, 16:06 UTC

This incident has been resolved. If customers have any questions about invoices or billing, please contact support@fastly.com or reach out to your account manager.