Retrospective: Historical Stats Performance Issues

Incident
21 April 2023, 18:30 UTC

Retrospective: Historical Stats Performance Issues

Status: closed
Start: 21 April 2023, 17:10 UTC
End: 21 April 2023, 18:30 UTC
Duration: 1 hour 20 minutes
Affected Components:
Observability Historical Stats
Affected Groups:
All Public Users
Update

21 April 2023, 17:10 UTC

21 April 2023, 17:10 UTC

Fastly Engineers detected a performance impacting event affecting the Historical Stats service.

All other data centers and services were unaffected.

The issue has been resolved and we are monitoring performance closely.

Resolved

21 April 2023, 18:30 UTC

21 April 2023, 18:30 UTC

This incident has been resolved.