developer.fastly.com Performance Issues

Incident
21 April 2023, 20:10 UTC

developer.fastly.com Performance Issues

Status: closed
Start: 19 April 2023, 11:12 UTC
End: 21 April 2023, 20:10 UTC
Duration: 2 days 8 hours 58 minutes
Affected Components:
Customer Services https://www.fastly.com/
Affected Groups:
All Public Users
Investigating

19 April 2023, 11:12 UTC

19 April 2023, 11:12 UTC

We are currently investigating performance issues affecting the functionality of developer.fastly.com. CDN delivery, stats aggregation, and all other data plane services are unaffected.

Monitoring

21 April 2023, 19:22 UTC

21 April 2023, 19:22 UTC

A fix has been implemented and we are monitoring the results.

If you are experiencing issues with the Developer Hub, please clear your browser cache.


Resolved

21 April 2023, 20:10 UTC

21 April 2023, 20:10 UTC

This incident has been resolved