Issue With Agent Packages

Incident
04 April 2023, 20:40 UTC

Issue With Agent Packages

Status: closed
Start: 04 April 2023, 14:55 UTC
End: 04 April 2023, 20:40 UTC
Duration: 5 hours 44 minutes
Affected Components:
Security Agents and Module Agent Downloads
Affected Groups:
All Public Users
Identified

04 April 2023, 14:55 UTC

04 April 2023, 14:55 UTC

Fastly engineers are aware of a recent change to some package file names due to a new release process. We are currently working on a fix for this issue.

All other services are unaffected.

Identified

04 April 2023, 18:30 UTC

04 April 2023, 18:30 UTC

This issue has been identified and a fix is being implemented.

Customers seeing errors pulling from our Alpine apk repository via apk can pull .apk packages manually from our apk site: https://apk.signalsciences.net/?prefix=3.17/main/ or download site: https://dl.signalsciences.net/?prefix=sigsci-agent/4.39.1/alpine/

Cloud Foundry customers can set the SIGSCI_DISABLE_CHECKSUM_INTEGRITY_CHECK environment variable as true to disable the package checksum verification during the install process until a fix is released.

Monitoring

04 April 2023, 20:21 UTC

04 April 2023, 20:21 UTC

A fix has been implemented and we are monitoring the results.

Resolved

04 April 2023, 20:40 UTC

04 April 2023, 20:40 UTC

This incident has been resolved.