Elevated Errors for New User Sign-up to Compute@Edge Services

Incident
03 March 2023, 14:57 UTC

Elevated Errors for New User Sign-up to Compute@Edge Services

Status: closed
Start: 03 March 2023, 13:50 UTC
End: 03 March 2023, 14:57 UTC
Duration: 1 hour 6 minutes
Affected Components:
Customer Services https://www.fastly.com/
Affected Groups:
All Public Users
Update

03 March 2023, 13:50 UTC

03 March 2023, 13:50 UTC

We're investigating elevated errors with our Compute@Edge new user sign-up form. New user sign-up is currently not available through https://www.fastly.com/signup/edge-compute  

New user sign-up is still available through https://www.fastly.com/signup/ for all services, including Compute@Edge.

Current customer Compute@Edge performance and all other services are unaffected.

Resolved

03 March 2023, 14:57 UTC

03 March 2023, 14:57 UTC

This incident has been resolved and our Compute@Edge new user sign-up form has been restored.