Compute@Edge Configuration Propagation Performance Issues

Incident
24 January 2023, 23:42 UTC

Compute@Edge Configuration Propagation Performance Issues

Status: closed
Start: 24 January 2023, 20:52 UTC
End: 24 January 2023, 23:42 UTC
Duration: 2 hours 50 minutes
Affected Components:
Edge Cloud Platform Compute Security Third Party Service Provider Europe Compute Services South America NGWAF@Edge Bogota (BOG) Buenos Aires (EZE) Curitiba (CWB) Fortaleza (FOR) Lima (LIM) Rio de Janeiro (GIG) Santiago (SCL) Rome (FCO)
Investigating

24 January 2023, 20:52 UTC

24 January 2023, 20:52 UTC

We’re currently investigating performance issues with Compute@Edge configuration propagation. All other services are unaffected.


Identified

24 January 2023, 21:29 UTC

24 January 2023, 21:29 UTC

This issue has been identified and a fix is being implemented. 

Update

24 January 2023, 21:56 UTC

24 January 2023, 21:56 UTC

Our investigations have identified common network provider issues related to the performance impact for our Compute@Edge services and NGWAF@Edge updates and decision making. Existing rules are operational, but new data is parsed at a slower pace. Fastly Engineering is in the process of performing standard traffic engineering to restore Compute@Edge and NGWAF@Edge services to pre-incident levels. 

Monitoring

24 January 2023, 22:22 UTC

24 January 2023, 22:22 UTC

A fix has been implemented and we are monitoring the results.

Resolved

24 January 2023, 23:42 UTC

24 January 2023, 23:42 UTC

Fastly has performed traffic engineering to route around the global network provider currently experiencing impact. Our Compute@Edge and NGWAF@Edge services are performing at pre-incident levels. 

This incident is resolved.