New York (NYC) New Data Center

Maintenance
16 January 2023, 11:00 UTC

New York (NYC) New Data Center

Status: closed
Start: 16 January 2023, 08:00 UTC
End: 16 January 2023, 11:00 UTC
Duration: 3 hours
Affected Components:
Edge Cloud Platform North America New York (NYC)
Update

16 January 2023, 08:00 UTC

16 January 2023, 08:00 UTC

As part of Fastly’s global network expansion, we will be adding New York (NYC) data center to Fastly's North America network. 

Traffic served by our New York (NYC) data center will be aggregated into our North America region for billing and stats purposes. We expect that some traffic currently served by our data centers in neighboring regions will shift to New York (NYC). As such, some customers may see a change in their bills.

Fastly’s standard billing rates are located at https:/www.fastly.com/pricing.

Resolved

16 January 2023, 11:00 UTC

16 January 2023, 11:00 UTC

The scheduled maintenance has been completed.