Issues with Fastly Status Page

Incident
16 March 2020, 23:50 UTC

Issues with Fastly Status Page

Status: closed
Start: 16 March 2020, 22:06 UTC
End: 16 March 2020, 23:50 UTC
Duration: 1 hour 43 minutes
Affected Components:
Affected Groups:
All Public Users
Investigating

16 March 2020, 22:06 UTC

16 March 2020, 22:06 UTC

The Fastly status page is currently experiencing intermittent performance issues. We are working with our partner to investigate further, but communications may be interrupted or delayed as they work to troubleshoot. All edge cloud products and services are unaffected.

Monitoring

16 March 2020, 22:47 UTC

16 March 2020, 22:47 UTC

A fix has been implemented and we are monitoring the results.

Resolved

16 March 2020, 23:50 UTC

16 March 2020, 23:50 UTC

This incident has been resolved.