Globalsign Intermediate Certificate Rotation

Maintenance
27 August 2021, 22:04 UTC

Globalsign Intermediate Certificate Rotation

Status: closed
Start: 24 August 2021, 09:30 UTC
End: 27 August 2021, 22:04 UTC
Duration: 3 days 12 hours 34 minutes
Affected Components:
TLS Provisioning
Affected Groups:
All Public Users
Update

24 August 2021, 09:30 UTC

24 August 2021, 09:30 UTC

On August 24, 2021 GlobalSign will rotate their Atlas TLS CAs intermediate certificates. Beginning 2022, GlobalSign will start rotating their intermediate certificates on a quarterly basis, on the second Monday of every quarter. For customers who are using Fastly TLS managed certificates issued by GlobalSign, also known as Fastly TLS Commercial CA, this change will require action on your part if you are using certificate or public key pinning to avoid any impact to your traffic. For more information on the update from GlobalSign, please refer to the following links: https://www.globalsign.com/en/blog/upcoming-changes-publicly-trusted-tls-certificates https://support.globalsign.com/atlas/atlas-tls/atlas-tls-ica-rotations-2021

Update

24 August 2021, 09:30 UTC

24 August 2021, 09:30 UTC

Please be advised that the time of this maintenance event has changed from Aug 24, entire day to Aug 24, 10:30 - 11:00 UTC.

Update

24 August 2021, 09:30 UTC

24 August 2021, 09:30 UTC

The time for this to take place is: 9:30-10:00 UTC.

Update

24 August 2021, 09:30 UTC

24 August 2021, 09:30 UTC

Maintenance will begin as scheduled in 60 minutes.

Resolved

27 August 2021, 22:04 UTC

27 August 2021, 22:04 UTC

The scheduled maintenance has been completed.