Upcoming Maintenance to Let’s Encrypt Certificates

Maintenance
01 October 2021, 18:42 UTC

Upcoming Maintenance to Let’s Encrypt Certificates

Status: closed
Start: 30 September 2021, 00:00 UTC
End: 01 October 2021, 18:42 UTC
Duration: 1 day 18 hours 42 minutes
Affected Components:
TLS Provisioning
Affected Groups:
All Public Users
Update

30 September 2021, 00:00 UTC

30 September 2021, 00:00 UTC

On May 4th, 2021, Let's Encrypt began issuing certificates with a trust chain that includes its ISRG Root X1 certificate cross-signed by IdenTrust's DST Root CA X3 certificate. On September 30th, 2021, the DST Root CA X3 certificate will expire. Most devices trust the ISRG Root X1 certificate directly and will be unaffected by this expiration. This certificate chain allows us to extend the compatibility for Android devices supporting versions prior to 7.1.1 for an additional three (3) years. For customers who require support for Android devices older than Android 7.1 and who provide their own Let’s Encrypt certificates with our Platform TLS, Legacy Customer-Provided TLS Certificate Hosting Service, or Fastly TLS products, the change to Let's Encrypt's certificate chain will not require action on your part to avoid any impact on your traffic. For customers using OpenSSL versions prior to 1.1, this certificate expiration will reject the Android-compatible chain, regardless of whether you have ISRG Root X1 in their trust store. For more information on Let's Encrypt's certificate changes, their expiration, and actions you may need to take, refer to their posted details on the subject: - https://letsencrypt.org/2020/12/21/extending-android-compatibility.html - https://community.letsencrypt.org/t/production-chain-changes/150739 - https://community.letsencrypt.org/t/openssl-client-compatibility-changes-for-let-s-encrypt-certificates/143816 For general questions about this announcement, contact our customer support team at fastlytlsupdates@fastly.com.

Update

30 September 2021, 00:00 UTC

30 September 2021, 00:00 UTC

Maintenance will begin as scheduled in 60 minutes.

Update

30 September 2021, 00:00 UTC

30 September 2021, 00:00 UTC

Scheduled maintenance is currently in progress. We will provide updates as necessary.

Resolved

01 October 2021, 18:42 UTC

01 October 2021, 18:42 UTC

The scheduled maintenance has been completed.