Retirement of legacy geolocation database

Maintenance
27 May 2022, 16:00 UTC

Retirement of legacy geolocation database

Status: closed
Start: 02 May 2022, 23:20 UTC
End: 27 May 2022, 16:00 UTC
Duration: 24 days 16 hours 40 minutes
Affected Components:
Compute Geolocation Data
Affected Groups:
All Public Users
Update

02 May 2022, 23:20 UTC

02 May 2022, 23:20 UTC

As described in our April 7, 2022 deprecation of support notice, a third-party vendor for one of Fastly’s geolocation databases is retiring their legacy geoip database. Fastly engineering team will start performing maintenance as part of the retirement of the legacy geoip.* VCL variables beginning May 9th, 2022 at 16:00 UTC. All Fastly services still using the legacy geolocation variables will be migrated by Fastly to the geolocation database using the client.geo.* variables between May 9th 2022 and May 27th 2022. The two sets of geolocation variables use databases from two different third-party vendors and some variable values differ between the two vendors. Fastly has documented the notable differences between the two sets of variables on our Developer Hub here: https://developer.fastly.com/reference/vcl/variables/geolocation/ Starting May 27th 2022, Fastly will no longer support the legacy geolocation geoip.* VCL variables and all instances of them in Fastly services must be removed by this date. Customers should use the client.geo.* variables for geolocation data in all new and existing Fastly services. Additional details have been emailed to known impacted customers from Fastly Customer Support. If you have any questions or concerns you can contact Fastly’s Support team at support@fastly.com.

Update

09 May 2022, 14:59 UTC

09 May 2022, 14:59 UTC

Maintenance will begin as scheduled in 60 minutes.

Update

09 May 2022, 16:00 UTC

09 May 2022, 16:00 UTC

Scheduled maintenance is currently in progress. We will provide updates as necessary.

Resolved

27 May 2022, 16:00 UTC

27 May 2022, 16:00 UTC

The scheduled maintenance has been completed.