Purging System Performance Issues

Incident
03 June 2022, 19:25 UTC

Purging System Performance Issues

Status: closed
Start: 03 June 2022, 15:59 UTC
End: 03 June 2022, 19:25 UTC
Duration: 3 hours 26 minutes
Affected Components:
Purging
Affected Groups:
All Public Users
Investigating

03 June 2022, 15:59 UTC

03 June 2022, 15:59 UTC

We're currently investigating performance issues with our URL and Surrogate Key purging services. All other services are unaffected.

Identified

03 June 2022, 17:35 UTC

03 June 2022, 17:35 UTC

The issue has been identified and a fix is being implemented.

Identified

03 June 2022, 18:38 UTC

03 June 2022, 18:38 UTC

A fix has been implemented, resulting in improved cloning and purging service performance. However, the service is working through a backlog of requests, and customers may continue to experience further delays. All other services remain unaffected.

Monitoring

03 June 2022, 19:13 UTC

03 June 2022, 19:13 UTC

A fix has been implemented and we are monitoring the results.

Resolved

03 June 2022, 19:25 UTC

03 June 2022, 19:25 UTC

This incident has been resolved.