Incident - Billing System Correction

Informational
02 July 2022, 00:02 UTC

Incident - Billing System Correction

Status: closed
Date: 01 July 2022, 22:02 UTC
End: 06 July 2022, 22:39 UTC
Duration: 5 days 36 minutes
Affected Components:
Customer Services Billing System
Affected Groups:
All Public Users
Investigating

01 July 2022, 22:02 UTC

01 July 2022, 22:02 UTC

Fastly is currently investigating an issue with our billing processor impacting developer and open source accounts only. We are auditing impacted invoices and will be issuing corrections within four business days. Impacted developers and open source customers will receive an email with a Fastly Service Advisory (FSA) providing additional detail. There is no impact to production services or traffic.

Identified

02 July 2022, 00:01 UTC

02 July 2022, 00:01 UTC

We have identified the impacted developer and open source customers, and a fix is being implemented. Corrections will begin in the next 24 hours.

Resolved

02 July 2022, 00:02 UTC

02 July 2022, 00:02 UTC

This incident has been resolved.