Incident - Billing System Issues

Incident
28 July 2022, 19:48 UTC

Incident - Billing System Issues

Status: closed
Start: 28 July 2022, 17:23 UTC
End: 28 July 2022, 19:48 UTC
Duration: 2 hours 24 minutes
Affected Components:
Billing System
Affected Groups:
All Public Users
Investigating

28 July 2022, 17:23 UTC

28 July 2022, 17:23 UTC

Fastly is currently investigating an issue with the billing system, including the billing portions of the Fastly configuration application and API. Edge delivery, stats aggregation, and all other services are unaffected.

Resolved

28 July 2022, 19:48 UTC

28 July 2022, 19:48 UTC

This incident has been resolved.