Billing Service Delay

Informational
05 August 2022, 17:12 UTC

Billing Service Delay

Status: closed
Date: 01 August 2022, 20:08 UTC
End: 08 August 2022, 19:29 UTC
Duration: 6 days 23 hours 20 minutes
Affected Components:
Customer Services Billing System
Affected Groups:
All Public Users
Monitoring

01 August 2022, 20:08 UTC

01 August 2022, 20:08 UTC

Fastly Billing is currently performing a series of routine checks on our billing process to ensure optimal accuracy for our August 1st billing cycle. As a result of these checks customers may experience a delay receiving their invoice. There is no impact to production services or traffic.

Monitoring

05 August 2022, 17:11 UTC

05 August 2022, 17:11 UTC

Fastly Billing has completed our routine checks. As a result of these checks, customers who did not have charges in the month of July may have received an additional email notification confirming a $0.00 balance. There are no further actions to take in response to this notification.

Resolved

05 August 2022, 17:12 UTC

05 August 2022, 17:12 UTC

All routine checks have been completed. Invoices can be accessed through standard methods.